Problems while searching for a new upstream version

package:
gnumed-server
severity:
high
created:
2019-06-01
last updated:
2019-06-26

uscan had problems while searching for a new upstream version:
In watch file debian/watch, reading webpage
  https://www.gnumed.de/downloads/server/ failed: 500 Can't connect to www.gnumed.de:443 (certificate verify failed)