version in VCS is newer than in repository, is it time to upload?

package:
python-mkdocs
severity:
normal
created:
2019-07-20
last updated:
2020-01-14

vcswatch reports that this package seems to have a new changelog entry (version 1.0.4+dfsg-2, distribution UNRELEASED) and new commits in its VCS. You should consider whether it's time to make an upload.

Here are the relevant commit messages:
commit 2fa7babfdd128bb93e58126040d894f47b9967cc
Merge: 0773001 c9eca48
Author: Jelmer Vernooij <jelmer@debian.org>
Date:   Mon Jan 13 22:03:15 2020 +0000

    Merge branch 'lintian-fixes' into 'debian/master'
    
    Fix some issues reported by lintian
    
    See merge request python-team/modules/python-mkdocs!1

commit c9eca480973ba9ca48bed0a2dc87a019b3dbf48b
Author: Debian Janitor <janitor@jelmer.uk>
Date:   Tue Jan 7 20:20:05 2020 +0000

    Set upstream metadata fields: Bug-Database, Bug-Submit.
    
    Fixes: lintian: upstream-metadata-file-is-missing
    See-also: https://lintian.debian.org/tags/upstream-metadata-file-is-missing.html

commit adde28afa0ab5c2b73668c3e06505f900ac2a40d
Author: Debian Janitor <janitor@jelmer.uk>
Date:   Tue Jan 7 20:19:39 2020 +0000

    Bump debhelper from old 11 to 12.
    
    Fixes: lintian: package-uses-old-debhelper-compat-version
    See-also: https://lintian.debian.org/tags/package-uses-old-debhelper-compat-version.html

commit 077300136c4c4db1c52789b9e4774f6413bee83a
Author: Ondřej Nový <onovy@debian.org>
Date:   Sat Jul 20 00:06:32 2019 +0200

    Use debhelper-compat instead of debian/compat