version in VCS is newer than in repository, is it time to upload?

package:
php-horde-vfs
severity:
normal
created:
2019-09-04
last updated:
2019-10-18

vcswatch reports that this package seems to have a new changelog entry (version 2.4.0-4, distribution UNRELEASED) and new commits in its VCS. You should consider whether it's time to make an upload.

Here are the relevant commit messages:
commit ba63c52660a8b00bdeb0ee053258d5201ce02610
Author: Mathieu Parent <math.parent@gmail.com>
Date:   Fri Oct 18 06:55:27 2019 +0200

    d/control: Orphaning package (See #942282)

commit ff8a14cba86d8bd6c6b3d342a85f5187549733d1
Author: Mathieu Parent <math.parent@gmail.com>
Date:   Wed Sep 4 21:19:00 2019 +0200

    Bump debhelper from old 11 to 12.
    
    Fixes lintian: package-uses-old-debhelper-compat-version
    See https://lintian.debian.org/tags/package-uses-old-debhelper-compat-version.html for more details.