version in VCS is newer than in repository, is it time to upload?

package:
liblog-dispatch-array-perl
severity:
normal
created:
2020-02-22
last updated:
2020-08-10

vcswatch reports that this package seems to have a new changelog entry (version 1.003-2, distribution UNRELEASED) and new commits in its VCS. You should consider whether it's time to make an upload.

Here are the relevant commit messages:
commit 49c9092abfdd6e378c05378e6131a8aaf5c640e0
Author: Debian Janitor <janitor@jelmer.uk>
Date:   Mon Apr 27 07:39:06 2020 +0000

    Remove obsolete fields Contact, Name from debian/upstream/metadata (already present in machine-readable debian/copyright).

commit 13407cf29d598c677eca88f0f30a96ea733a46be
Author: Debian Janitor <janitor@jelmer.uk>
Date:   Mon Apr 27 07:38:31 2020 +0000

    Set upstream metadata fields: Bug-Submit.
    
    Fixes: lintian: upstream-metadata-missing-bug-tracking
    See-also: https://lintian.debian.org/tags/upstream-metadata-missing-bug-tracking.html

commit dec31d4676fe7abcf8acc3872ac4da97b1361a36
Author: Debian Janitor <janitor@jelmer.uk>
Date:   Mon Apr 27 07:37:56 2020 +0000

    Set debhelper-compat version in Build-Depends.
    
    Fixes: lintian: uses-debhelper-compat-file
    See-also: https://lintian.debian.org/tags/uses-debhelper-compat-file.html

commit 8f33e281976b1a5de812bc5c549281ce44208c1f
Author: Debian Janitor <janitor@jelmer.uk>
Date:   Mon Apr 27 07:37:12 2020 +0000

    Bump debhelper from old 10 to 12.
    
    Fixes: lintian: package-uses-old-debhelper-compat-version
    See-also: https://lintian.debian.org/tags/package-uses-old-debhelper-compat-version.html

commit dd0e840aa19a20cfdbf5d215a2a4e66452c7442d
Author: gregor herrmann <gregoa@debian.org>
Date:   Sat Feb 22 16:41:04 2020 +0100

    update changelog
    
    Gbp-Dch: Ignore

commit 113e61d1f320deb0c439f8d285262cbb08a5053c
Author: gregor herrmann <gregoa@debian.org>
Date:   Sat Feb 22 16:41:04 2020 +0100

    debian/watch: use uscan version 4.