3 ignored security issues in jessie

package:
ocaml
severity:
low
created:
2016-04-29
last updated:
2019-01-31

There are 3 open security issues in jessie.
3 issues skipped by the security teams:
  • CVE-2015-8869: OCaml before 4.03.0 does not properly handle sign extensions, which allows remote attackers to conduct buffer overflow attacks or obtain sensitive information as demonstrated by a long string to the String.copy function.
  • CVE-2018-9838: The caml_ba_deserialize function in byterun/bigarray.c in the standard library in OCaml 4.06.0 has an integer overflow which, in situations where marshalled data is accepted from an untrusted source, allows remote attackers to cause a denial of service (memory corruption) or possibly execute arbitrary code via a crafted object.
  • CVE-2017-9779: OCaml compiler allows attackers to have unspecified impact via unknown vectors, a similar issue to CVE-2017-9772 "but with much less impact."
Please fix them.