Problems while searching for a new upstream version

package:
libidna-punycode-perl
severity:
high
created:
2017-11-21
last updated:
2019-03-23

uscan had problems while searching for a new upstream version:
In watchfile debian/watch, reading webpage
  https://metacpan.org/release/IDNA-Punycode failed: 404 Not Found