version in VCS is newer than in repository, is it time to upload?

package:
nb2plots
severity:
normal
created:
2018-06-06
last updated:
2019-07-20

vcswatch reports that this package seems to have a new changelog entry (version 0.6-2, distribution UNRELEASED) and new commits in its VCS. You should consider whether it's time to make an upload.

Here are the relevant commit messages:
commit 6cc9b592a08edc3e8b590aeb3c7df3f09667a65f
Author: Ondřej Nový <onovy@debian.org>
Date:   Fri Jul 19 23:45:05 2019 +0200

    Use debhelper-compat instead of debian/compat

commit 65805b19a187d9908937830154929888fe4f14fc
Author: Chris Lamb <lamby@debian.org>
Date:   Mon Sep 17 17:04:52 2018 +0100

    Remove trailing whitespaces.

commit e459e45fc65ab3dfa0651c285784eebbdcd0f465
Author: Sandro Tosi <morph@debian.org>
Date:   Thu Jun 7 17:27:30 2018 -0400

    add nbformat to depends, needed by the ipython shim module

commit c6fb3f64a91234a0203c5d90d0ae99a42a800bae
Author: Chris Lamb <lamby@debian.org>
Date:   Thu May 17 09:57:36 2018 +0200

    debian/copyright: Use HTTPS for Source field.

commit 92f44dd9df432ca6f0ec040a176ff4369176293a
Author: Chris Lamb <lamby@debian.org>
Date:   Thu May 17 09:50:52 2018 +0200

    debian/control: Use HTTPS for Homepage field.