version in VCS is newer than in repository, is it time to upload?

package:
libcpandb-perl
severity:
normal
created:
2018-09-03
last updated:
2020-05-26

vcswatch reports that this package seems to have a new changelog entry (version 0.18-3, distribution UNRELEASED) and new commits in its VCS. You should consider whether it's time to make an upload.

Here are the relevant commit messages:
commit 6b637f807800d1b82be0b6acc44b4f886d21d510
Author: gregor herrmann <gregoa@debian.org>
Date:   Sat Feb 22 16:37:06 2020 +0100

    update changelog
    
    Gbp-Dch: Ignore

commit a2b460aca45aff1e97cc19394a43582fac2e9260
Author: gregor herrmann <gregoa@debian.org>
Date:   Sat Feb 22 16:37:06 2020 +0100

    debian/watch: use uscan version 4.

commit 1a7aa032f58a019b9f36ef75a46c3fe2f512064e
Merge: c628047 bbe1e8d
Author: gregor herrmann <gregoa@debian.org>
Date:   Sun Dec 15 22:11:57 2019 +0000

    Merge branch 'lintian-fixes' into 'master'
    
    Fix some issues reported by lintian
    
    See merge request perl-team/modules/packages/libcpandb-perl!1

commit bbe1e8d014320773976dd0695223be2e47c1cd29
Author: Debian Janitor <jelmer+janitor@jelmer.uk>
Date:   Sat Dec 14 15:27:51 2019 +0000

    Add missing build dependency on libmodule-install-perl.

commit a8f1e1ad7fe5839c7ceb5d0e88945973713983f5
Author: Debian Janitor <janitor@jelmer.uk>
Date:   Sat Dec 14 15:26:13 2019 +0000

    Set upstream metadata fields: Repository.
    
    Fixes lintian: upstream-metadata-file-is-missing
    See https://lintian.debian.org/tags/upstream-metadata-file-is-missing.html for more details.

commit 72fd4cf8fa86c3a351b08408dd9a8d24bd65bd8e
Author: Debian Janitor <janitor@jelmer.uk>
Date:   Sat Dec 14 15:25:53 2019 +0000

    Set debhelper-compat version in Build-Depends.
    
    Fixes lintian: uses-debhelper-compat-file
    See https://lintian.debian.org/tags/uses-debhelper-compat-file.html for more details.

commit ff3e1a025202b0b3e836fa0738ccbf76cb30e2ec
Author: Debian Janitor <janitor@jelmer.uk>
Date:   Sat Dec 14 15:25:33 2019 +0000

    Bump debhelper from old 10 to 12.
    
    Fixes lintian: package-uses-old-debhelper-compat-version
    See https://lintian.debian.org/tags/package-uses-old-debhelper-compat-version.html for more details.

commit c628047edcee280815d0972e6230bee50abfb930
Author: Xavier Guimard <yadd@debian.org>
Date:   Sun Sep 2 22:22:32 2018 +0200

    Email change Xavier Guimard -> yadd@debian.org